Indianapolis Region storm impact

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 13:28 EDT

Monitoring

Our crews are continuing to monitor the impact of power outages at several locations in Indianapolis, and performing steps to resolve any outstanding issues.
Posted Jun 19, 2025 - 12:00 EDT

Identified

We are currently tracking several outages related to storm damage in the indianapolis region. We are investigating and working to resolve as quickly as possible.
Posted Jun 18, 2025 - 16:58 EDT