West Lafayette Region Outage - Provenance Homes & Apartments

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 19:51 EDT

Investigating

We are currently investigating an outage impacting the West Lafayette region.

Impacted locations: Provenance Homes & Apartments
Current service restoration ETA: 10:00pm
Posted Jun 18, 2025 - 17:30 EDT