26 West Outage

Incident Report for Haywire

Resolved

This incident has been resolved.
Posted Aug 15, 2025 - 09:10 EDT

Identified

We have a crew onsite and have identified a failed power unit as the cause. Repairs are expected to be complete by 8:45am.
Posted Aug 15, 2025 - 07:59 EDT

Investigating

A power event has taken our equipment offline at 26 West. We are dispatching a crew to investigate.
Posted Aug 15, 2025 - 06:06 EDT